آموزش کار با MultiPHP Manager در cpanel

آموزش کار با MultiPHP Manager در cpanel

دوستان عزیز پیشگام وبی امیدوارم که حالتون خوب باشه ، امروز با آموزش کار با MultiPHP Manager در cpanel خدمتتون هستیم و امیدوارم توضیحاتی که در این مطلب و یا در انتها مطلب که بصورت فیلم قرارداده شده بتونه به شما کمک کنه و هر روز بیشتر پیشرفت کنید.

خوب اصلا این قسمت به چه دردی میخوره کجا بهش نیاز داریم و در کل کاربردش چی هست؟

این قسمت برای تغییر پسورد در سی پنل میباشد که با عنوان MultiPHP Manager در قسمت Software موجود میباشد.

ابتدا وارد هاستمون داخل سایت پیشگام وب میشیم.

میتوانیم از سرویس های من ورود به سی پنل رو میزنید تا بصورت اتوماتیک وارد هاستمون بشیم.

MultiPHP Manager در cpanel

بعد از ورود به قسمت Software و کلیک روی گزینه MultiPHP Manager وارد صفحه زیر میشویم.

ما در این قسمت همانند سلکت پی اچ پی ورژن میتوانیم نسخه پی اچ پی هاست را مشخص کنیم ، فقط با این تفاوت که نسخه پی اچ پی بر اساس دامنه یا ساب دامنه قابل انتخاب میباشد در صورتی که در قسمت سلکت پی اچ پی ورژن بصورت کلی برای تمامی دامنه و ساب دامنه های روی هاست میباشد.

کاربرد این قسمت زمانی میباشد که شما یک اسکریپت دارید که حتما باید با نسخه 5.4 ست شود و یک اسکریپت هم در ساب دامنه یا دامنه دیگری دارید که باید نسخه پی اچ پی آن حداقل 7.0 باشد در غیر اینصورت سایت ناقص لود میگردد.

در کنار دامنه ، دامنه مد نظر را انتخاب کرده و در قسمت php version هم نسخه پی اچ پی مورد نظر را مشخص کرده و روی گزینه apply کلیک کنید تا ست شود.

پس از apply در قسمت PHP Version که روبروی دامنه میباشد میتوانید نسخه پی اچ پی که به نسخه مورد نظر شما تغییر کرده است را مشاهده کنید.

مشاهده فیلم آموزشی از سایت آپارات

 

برای دانلود فیلم آموزش از قسمت تنظیمات روی گزینه دانلود کلیک کرده و کیفیت مد نظر خود را انتخاب کنید تا فیلم آموزش دانلود گردد.

نکته : هر چقدر که عدد این قسمت بیشتر باشد ، کیفیت فیلم دانلودی بالاتر خواهد بود.

آموزش های ابتدایی :

دوستان عزیز آموزش که خدمتتون ارائه کردیم از سری آموزش های ابتدایی پیشگام وب هست و این آموزش جزو پایه ای ترین آموزش های سایت هست امیدوارم که آموزشممون کامل باشه.

منتظر نظرات و پیشنهادات شما در قسمت دیدگاه های سایت هستیم.

learn in cpanel

Overview

cPanel’s MultiPHP Manager interface allows you to easily manage your account’s PHP configuration. In this interface, you can manage the PHP version or pool option of any virtual host.

  • The system PHP version refers to version of PHP that functions as the global default for all accounts. Only the system administrator can set the system PHP version. Any primary domain that is set to Inherit uses the system PHP version. For more information, read our PHP Inheritance documentation.

  • PHP FastCGI Process Manager (PHP-FPM) is an alternative PHP module that allows a website to handle strenuous loads on sites. PHP-FPM maintains pools (workers that respond to PHP requests) to accomplish this. These pools of workers allow the website to handle more requests than it normally could.

List of domains

The list of domains displays the following information:

  • The name of the domain.

  • The PHP version that the domain currently uses.

    Note:

    In EasyApache 4, each domain or virtual host can use any currently-installed PHP version or currently-installed PHP-FPM setting.

     

  • The Inherited label, if the domain inherits its PHP version from the system PHP version.

  • A PHP-FPM enabled () or disabled () indicator.

    Note:
    • Parked domains represent aliases for a primary domain. The system does not list parked domains.
    • System administrators can enable or disable PHP-FPM through WHM’s MultiPHP Manager interface (WHM >> Home >> Software >> MultiPHP Manager).

     

Use the Search text box to search domains by domain name or account name.

Set the PHP version for a domain

Note:

EasyApache 4 supports PHP versions 5.4 through 5.6, PHP versions 7.0 through 7.4, and PHP 8.0. The cPanel default profile includes PHP versions 7.2, 7.3, and 7.4.

To change a domain’s PHP version, perform the following steps:

  1. Select the checkbox for the domain that you wish to change.

  2. Select the desired version of PHP from the PHP Version menu. To always use the system default, select inherit.

    Note:
    • If the system administrator recommends any PHP versions, the menu will display the Recommended label next to them.

    • If you set your PHP version to inherit, the system will not allow you to set PHP-FPM. You must select a PHP version other than inherit to enable PHP-FPM on a domain.

    • If the PHP version that you want to use does not appear, that PHP version is either not installed on the server or is not available for your account.

    • If your system administrator limited your domain’s PHP version, then you cannot use this interface to restore the domain’s PHP version to its original version.

     

  3. Click Apply. The system will change the selected domain’s PHP version.

    Note:
    • When you change the PHP version for your domain and FPM is enabled, the system changes your FPM version to match the PHP version. If FPM is not enabled on your domain, the system changes the PHP and FPM versions separately.

    • If you enable FPM on your primary domain and then change that domain’s name, the system will disable FPM for the new domain. Your system administrator or hosting provider must reenable FPM on the new domain if you wish to use FPM for the new domain.

     

More:

For more information regarding PHP versions and installation, read our How to Locate and Install a PHP Version of Extension documentation.

درباره نویسنده

نظرات شما


پنج + = 9

هجده + هفده =